Topic: PHP timeout when creating links

I've been testing out Enano today and I noticed some strange behavior when creating links in the GUI editor.

Some background on my setup:
Ubuntu 8.10
Apache 2.2.9
PHP 5.2.6
MySQL 5.0.67
Enano 1.0.6

When I create a link in the GUI editor and try to save or preview, cpu goes to 100% and after 30 seconds php reaches it's limit and exits.  Then I just get an error telling me that PHP reached it exec time limit and it doesn't save or preview.  But if I use the text editor all is well.

I tried several different configurations with Enano and also tried it in lighttpd.  I'm assuming that it's some kind of incompatability with my version of PHP but I'm not sure.

After this I installed Enano 1.0.5 and it works flawlessly.  Strange.

Has anyone else seen this problem?

BTW, I've been using DokiWiki for several years now and I'm seriously thinking about making a switch to Enano.  Great work on this app!

Re: PHP timeout when creating links

This might be a bug with TinyMCE as opposed to something directly related to Enano. I can't find anything between 1.0.5 and 1.0.6 that might have caused this. Try doing this in a different browser or clearing your cache. I'll see if I can get some debugging in later tonight.

Sorry for taking so long to respond, I've been swamped with development on unstable this past week.

Edit: hold on, I can think of something that might cause this. There was a change related to an XSS vulnerability that went into Enano 1.0.6. As this involved parsing of HTML tags, this could very well be your problem.

--Dan

Re: PHP timeout when creating links

Works for me under Ubuntu Jaunty 9.04 beta, Enano 1.0.7-hg, and Apache, PHP, and MySQL installed via apt. There haven't been any changes to anything related to page editing since 1.0.6, so I'm a bit confused on this one. Do you think you can give the file and line where PHP errors out?

--Dan

Re: PHP timeout when creating links

Hey Dan,
Don't worry about taking a while to respond.

I'm at work right now but I should have some time this weekend to find out where it's hanging.  I'll post back when I get to it.

Thanks for the reply.

Re: PHP timeout when creating links

Is the issue fixed in Enano 1.0.6pl1? If not, I'll try to figure out the problem and include a bugfix in 1.0.7.