Topic: PHP 4 support policy

As of December 31, 2007, Zend Corporation is discontinuing support for PHP 4.x.x. As a result of this move, on this date the Enano Project will stop providing support for any copy of Enano hosted on a server with PHP4. Version 4.x of PHP is several years old and constrains us developers because it lacks a number of important features. We are attempting to keep Enano 1.x compatible with PHP4-based servers, but at the same time we refuse to provide support for them. Remember that this policy will take effect until December 31; until then, we will provide PHP4 support as usual.

Depending on circumstances we may also code a minimum version requirement of PHP 5.2.0 as of February 5th, 2008 in compliance with GoPHP5.org. It will probably be implemented as a warning.

--Dan