Topic: greyhound help

hey dan,
i found this forum through your site about greyhound. Hope you don't mind me asking dopey questions. Im trying to run greyhound on my eee pc. I installed it through script manager in amarok and I think I found all the required packages. When I run it in script manager I get the error message:
[Greyhound] Starting Greyhound Web Control v0.1a4
When I run it from the root console it says:
php greyhound.php
[Greyhound] Starting Greyhound Web Control v0.1a4

Fatal error: Call to a member function is_child() on a non-object in /home/user/.kde/share/apps/amarok/scripts/greyhound/webserver.php on line 354

Any clue what's going on?

2 (edited by Dan 2009-01-05 04:03:51)

Re: greyhound help

The surface problem is that the WebServer's destructor is being called. That means Greyhound is trying to exit for some reason, but we might not know what that reason is until that error can be cleared up. I've committed a fix for the is_child() bug for you; you can get it here. Uninstall the version that you currently have in Amarok, and then save the version here with the filename "greyhound-0.1a5-hg.amarokscript.tar.bz2". Install it in Amarok and report back with any further error messages Greyhound gives you. I am fairly certain that the version here isn't going to fix your problem, but it might help me find out what the cause of your underlying problem is.

Edit: Also try starting Greyhound from a normal console (not a root shell).


Re: greyhound help

No change with the new version. When I run it from the console it just says:
/home/user/.kde/share/apps/amarok/scripts/Greyhound-c4aefad02ce4> php greyhound.php
[Greyhound] Starting Greyhound Web Control v0.1a4
and then drops back to the prompt. No errors..My php has error reporting on. I also tried to configure it to log errors to a file, but haven't had any luck. i know a little php, so let me know if I can do anything to hlp figure this out.